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NOTE:  
The actual results for the routes, miles, minutes, turntables etc. may, but should not, differ from your 
own result. 
 
PART 1 
 
Drunkin Donuts (DD) specializes in daily home delivery of gourmet donuts. DD has 2 facilities in the SLC 
area. As a GIS analyst, you have been asked to assist DD in analyzing their home delivery efficiency. 
 

1. Both facilities serve different customer groups. First, analyze the current best order in which the 
customers of each facility should be visited from their chosen supply facility. Make a note of the total 
time and total length traveled and provide it in your write-up. Give a brief description of the procedure 
in your report, and include screenshots where appropriate. (15 points) 

 
 
Step 1 - Geocoding and address matching 
 
Both facilities and customers are given as text files. In order to do route analysis you first need to geocode the 
road them and then match the addresses to the road theme, so that you can display them as shape files in 
your view. 
 
Start a new project in ArcView and load the slcroads.shp file into your view. 
 
Use View > Properties to set Map Units to feet and Working Units to miles. 
 
Make the project window active,  
Use the Tables > Add function to add the tables dd_cust1.txt, dd_cust2.txt and dd_fac.txt to your project. 
 
Make the road theme active and set its geocoding properties: 
Theme > Properties > Geocoding > US Single Range > OK 
 
Match the addresses: 
View > Geocode Addresses > slcroads.shp is the Reference Theme > dd_cust1.txt is the Address Table > 
Save the Geocoded Theme as cust1.shp in your directory > Batch Match > Done > The point theme is added 
to your view 
 
Repeat for dd_cust2 and dd_fac, save themes as cust2.shp and fac.shp. 
 
For dd_cust2 you should encounter a non-match. Do > Interactive Rematch > Match > Done > Done 
 
If you forget to save the geocoded addresses in your directory when matching. You can convert the default 
geocoded file to a shapefile: 
Make the default file active, Theme > Convert To Shapefile > Select name and folder > OK > Add to view 
The you can delete the default file: 
Make the default file active, Edit > Delete Theme 
 
Not necessary, but this will help identify the stops better: 
Make the cust1.shp theme active,  
View the attribute table, 
Then use Table > Properties > Set the Alias of Customer to be �Label� > OK. Repeat for cust2shp and fac.shp 
(Facility = Label). 
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Step 2 � Find best route 
 
Find the best route for facility 1: 
Make the road theme active, Network > Find Best Route > Load Stops > Load the fac.shp file, then highlight 
Stop#2 in the dialog box and delete it > Load Stops > Load the cust1.shp file > Check the box for Find Best 
Order and Return to Origin > Solve 
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2. The customers ideally should have chosen the facility nearest them. However, this appears not to be 

the case. Check to see if any customer can be reached in less time from a different facility than the 
one that serves him/her today. If so, reassign these customers and create 2 new customer groups, 
one for each facility. Determine the best order in which each customer should be served now. 
Compare the total time and total length traveled with the previous result. Provide the answers in your 
write-up. Give a brief description of the procedure in your report, and include screenshots where 
appropriate. Justify any decisions and assumptions that you make. (35 points) 

 
This is a facility versus customer location problem. The main goal is to find the distance from each facility to 
all customers and to see whether a customer has a shorter distance to the other facility than he/she is 
currently assigned to. This was NOT meant to be a Find Best Route problem. 
 
 
Step 1 � Find Nearest Facility 
 
Make the road theme active, 
Network > Find Nearest Facility > Select cust1.shp as Facilities > Set Number of facilities to find to 5 > Load 
Events > Select fac.shp > Select Travel from event > Solve 
 
This finds the distance in miles  from the facility to all customers in group 1. Record the values. 
 

 
 
 
Now, use the Properties function to set Minutes as the cost field to calculate the same distance in minutes. 
Record the values. 
 

 
 
Change Event from DD1 to DD2, repeat the procedure above. Record the values.  
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You have now found the distance from facility 1 and 2 to all customers from group 1. 
 
Change Facilities to cust2.shp. Run the same analysis with DD1 and DD2 as Event to calculate the distance 
in miles and minutes from facility 1 and 2 to all customers from group 2. 
 

   
 

   
 
There is not much difference between time and distance. The reason for this is that more or less all roads have an average speed of 35 
miles per hour. Consequently, solving the route for time basically produces the same result as solving it for distance. Another note: There 
is also no impedance for the stops, as if you were throwing out the donuts at high speed as you pass by, not very realistic, is it? 
Stops can be intricately modeled using Avenue scripts, but I leave that up to your own exploration. 
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Eventually you can record your results in a table like this: 
 

 
From Left to right: Customer, distance from facility 1 in miles, distance in minutes, miles from facility 2, minutes from facility 2, Currently 
assigned to, closest facility in miles, in minutes, proposed assigned to. 
 
Now you will have to edit the customer lists, re-match the addresses to create shape files and re-run Find 
Best Route with the new customer locations. 
 
Open cust1.txt and cust2,txt in Notepad. Cut-and-Paste the re-assigned customers. Save the files as 
cust1_new.txt and cust2>new.txt.  
 
Add the new tables to you project. 
 
Match the addresses using the same procedure as outlined previously. 
 
Alternatively, you can use the dialog box, load the stops for both customer groups, then delete the ones that 
should not be there and use Save Stops to create to new shape files. 
 
Use Find Best Route to find the new delivery routes from facility 1 and facility 2. 
 
First, facility 1: 

   
 

   

Customer Fac1_m Fac1_min Fac2_m Fac2_min Facility Best_m Best_min Assigned 
Mary  1.86 1.85 3.06 3.11 1 1 1 1 
Jack 2.39 2.37 2.54 2.58 1 1 1 1 
Bill 2.84 2.83 2.09 2.13 1 2 2 2 
Henry  3.85 3.88 4.03 4.04 1 1 1 1 
Stacy 2.56 2.86 4.17 4.20 1 1 1 1 
Brooke 1.24 1.25 4.48 4.50 2 1 1 1 
Melissa 2.71 2.72 4.25 4.22 2 1 1 1 
Oscar 4.40 4.37 4.09 4.08 2 2 2 2 
Jenny 4.40 4.43 0.57 0.57 2 2 2 2 
Fred 5.11 5.04 0.74 0.74 2 2 2 2 
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Note the difference in route delineation for miles versus minutes. 
 
 
Second, facility 2: 
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PART 2 
 
As a GIS analyst you have been asked to prepare the best route for the school bus to pick up a number of 
children. The only data you have is a line theme, not prepared for network analysis and a list of addresses for 
the children, plus the school and the bus depot.  
 

3. Prepare the network and find the best ordered route, compare total length and total time for the 
chosen route. The bus starts from the depot and returns to the depot after the trip. The bus driver 
needs directions, but only the first 5 and the last 5 turns, so also include these in your report. Give a 
brief description of the procedure, and include screenshots where appropriate. Justify any decisions 
and assumptions that you make. (35 points) 

 
As not to confues the 2 parts of the assignment, you better start with a new view. Close the view for part 1, 
make the project window active, View > New.   
 
 
Preparing the network 
 
Add the busroute.shp file to your view. 
 
 
Step 1 
 
First you need to build the topology. This is done by solving a network problem and then copying the node 
index to the busroute.shp attribute table: 
 
Make busroute.shp active, 
Network > Find best route > Use the graphic pick to select 2 stops arbitrarily > Solve 
 
Make the Project window active, 
Scripts > New 
Make the Script window active, 
Script > Load Text File > Select copynodes.ave from the scripts folder in the lab7 directory.  
The script is loaded into the Script window. Replace the following lines 
 
aView = av.GetProject.FindDoc("VIEW_NAME_HERE") 
aNetworkTheme = aView.FindTheme("THEME_NAME_HERE") 
 
with  
 
aView = av.GetProject.FindDoc("View2") 
aNetworkTheme = aView.FindTheme("Busroute.shp") USE THE NAMES IN YOUR PROJECT 
 
Script > Compile, Script > Run 
 
Looking at the busroute.shp attribute table, 3 fileds have been added: Rec# , Fjunction, Tjunction. This is the 
topology, where Rec# is the arc number, Fjunction is the from-node, Tjunction is the to-node. 
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Step 2 
 
The next step is to add the 3 fields for average speed along each arc, travel cost and directional constraints.  
 
Make the attribute table active, 
Table > Start Editing,  
Edit > Add Field > Call it mph, Type Number, Length 3, Decimals 0 > OK 
Edit > Add Field > Call it minutes, Type Number, Length 10, Decimals 2 > OK 
Edit > Add Field > Call it mph, Type String, Length 2, Decimals 0 > OK 
 

 
 
 
Step 3  
 
Now you need to populate the records for the new fields. 
 
Roads appear to be classified by the Road Code field, so you need to select the arcs that have the same 
value and set the appropriate mph value: 
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First, make the attribute table of busroute.shp editable: 
Make the attribute table of busroute.shp the active window, 
Table > Start Editing 
Use the Query Builder: 
Table > Query > ([Road_code] = 1) > New Set 
 

 
 
The associated arcs are now highlighted in the table and in the view. 
 
Now you need to calculate mph: 
Click on the mph column heading, then Field > Calculate > [mph] = 50 (my choice of value) > OK 
 

 
 
Go Back to the Query Builder, enter ([Road_code] = 2) > New Set 
Field > Calculate > [mph] = 30 > OK 
Go Back to the Query Builder, enter ([Road_code] = 3) > New Set 
Field > Calculate > [mph] = 20 > OK 
Go Back to the Query Builder, enter ([Road_code] = 4) > New Set 
Field > Calculate > [mph] = 10 > OK 
 
With the average speed defined, we can now calculate the travel time: 
Click on the minutes column heading, then Field > Calculate > Enter this formula: 
(60*[length])/(5280*[mph]) > OK 
 



Author: Jan Husdal.  Last updated: 4/30/02 12:12 PM

  

 SOLUTION                                                                                                                  Page 10 of 17 
 

If you encounter any problems, bugs or inconsistencies, please email me at gis@husdal.com. 

Finally, you ought to set directional constraints. This is particularly important for freeway ramps and lanes: 
 
Use the Select Features tool to select some freeway arcs, visually check their from-node (Fjunction) and to-
node (Tjunction) to ensure that the traffic direction coincides with the arc direction, enter ft in the oneway field 
if it does, if the direction is the opposite as in the example below, enter tf. 
 

 
 
Repeat until you�re certain that all arcs have been correctly constrained.  
 
This was not specifically part of the assignment, but will give you extra credit if you did. 
 
If you miss some arcs, don�t worry � the errors will show up when you solve a route, and you can then re-edit 
the attribute table if needed. 
 
Table > Stop Editing > Save Edits > concludes the network definition. Your network is now ready to roll! 
 
Tip: 
There�s an easy way to identify which ones need to be tf and which ones need to be ft: 
First select the arcs you want to look at, by using the Select Feature tool and then clicking on them, or by 
using the Query Builder, say, for freeways, since you know that the arcs have the same road code. Once 
selected, go back to the View window and double-click on busroute.shp to bring up the Legend Editor. 
Double-clicking the symbol brings up the Palette Editor. Select the Pen Palette (in the top row), then scroll 
down and select an arrow. Click Apply in the Legend Editor and voila, all arcs are now directed arcs. The one-
way streets and lanes that are correctly directed, are assigned a value of ft in the oneway field, the others are 
assigned tf, as shown below:  
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Geocoding and address matching 
 
As before the addresses are given as a text file, which you will have to match to the road theme: 
 
Make the project window active,  
Use the Tables > Add function to add the table assign2.txt to your project. 
 
Make the road theme active and set its geocoding properties: 
Theme > Properties > Geocoding > US Single Range > OK 
 
Match the addresses: 
View > Geocode Addresses > busroute.shp is the Reference Theme > assign2.txt is the Address Table > 
Save the Geocoded Theme as adresses.shp in your directory > Batch Match > Done > The point theme is 
added to your view. 
 
If you want to be really advanced, you can view the attribute table of addresses.shp, highlight the school and 
use Theme, Convert to Shapefile to separate the school and the depot from the schoolkids. This is not 
absolutely necessary, since you can arrange the order of the stops in the Solve dialog box before you solve 
the route. 
 
Finally, in order to display the children�s names in the solution, 
Make the adresses.shp attribute table active,  
Table > Properties > Enter Label as the Alias of Stop 
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Find Best Route 
 
Make busroute.shp active, 
Network > Find Best Route > Load addresses.shp as stops > Use the arrows to put the depot on top and the 
school at the bottom. Highlight all stops in the dialog box, except for school and depot. Check the box for Find 
best order > Solve 
 

  
 
Use Directions and Save to save the directions as text file, which you can then edit to find the first 5 and the 
last 5 turns in the route. Remember to first set the Direction Properties, after you click Directions, to make 
sure you are reporting in miles or minutes.  
 
First 5 turns, best route by distance, directions in miles: 
Starting from Bus depot 
Turn right onto Lake Park 
  Travel on Lake Park for 0.20 mi 
Turn right onto Corporate Park 
  Travel on Corporate Park for 0.28 mi 
Continue straight onto 4800 
  Travel on 4800 for 0.05 mi 
Continue straight onto Corporate Park 
  Travel on Corporate Park for 0.03 mi 
Turn left onto Fox Shadow 
  Travel on Fox Shadow for 0.20 mi 
Turn left into Bruno 
 
Last 5 turns, best route by distance, directions in miles: 
Starting from Kelly 
Turn left onto Hardrock 
  Travel on Hardrock for 0.11 mi 
Turn right onto Dutch Draw 
  Travel on Dutch Draw for 0.18 mi 
Turn left onto 2700 
  Travel on 2700 for 0.83 mi 
Turn left onto 4700 
  Travel on 4700 for 1.01 mi 
Turn right onto Redwood 
  Travel on Redwood for 0.37 mi 
Turn left into School 
 
 
First 5 turns, best route by time, directions in minutes: 
Starting from Bus depot 
Turn right onto Lake Park 
  Travel on Lake Park for 0.39 min 



Author: Jan Husdal.  Last updated: 4/30/02 12:12 PM

  

 SOLUTION                                                                                                                  Page 13 of 17 
 

If you encounter any problems, bugs or inconsistencies, please email me at gis@husdal.com. 

Turn right onto Corporate Park 
  Travel on Corporate Park for 0.57 min 
Continue straight onto 4800 
  Travel on 4800 for 0.10 min 
Continue straight onto Corporate Park 
  Travel on Corporate Park for 0.06 min 
Turn left onto Fox Shadow 
  Travel on Fox Shadow for 0.61 min 
Turn left into Bruno 
 
Last 5 turns, best route by time, directions in minutes: 
Starting from Kelly 
Turn left onto Hardrock 
  Travel on Hardrock for 0.35 min 
Turn right onto Dutch Draw 
  Travel on Dutch Draw for 0.52 min 
Turn left onto 2700 
  Travel on 2700 for 1.66 min 
Turn left onto 4700 
  Travel on 4700 for 2.01 min 
Turn right onto Redwood 
  Travel on Redwood for 0.74 min 
Turn left into School 
 
Use Theme > Convert to Shapefile to save the routes separately 
 
Then you need to find the best way back to the depot. Delete the school kids from the Solve dialog box and 
use Properties to solve for minutes and distance. Save the routes as shapefiles. 
 
Best route in minutes: 12.87 mins 
Best route in miles: 6.86 mi 
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4. Unfortunately for your route, UDOT is doing some major construction in your area: 5200W is now 

one-way only, Northbound, from 4100S to 3500S. 4400W is closed from 3100S to 3500S. Edit the 
attribute table to correspond with this. Include the necessary field names and values from the attribute 
table in your report. At the intersection of 4700S and 2700W, Southbound traffic cannot turn East 
onto 4700S from 2700W. Also, at the intersection of 3500S and 4800W, Northbound traffic cannot 
continue straight on 4800W or make a left turn West onto 3500S, but must make a right turn East 
onto 3500S. Make a turntable that reflects this, give a brief description of the procedure and include 
the values from table in your report. Include screenshots where appropriate. Justify any decisions and 
assumptions that you make. Re-run the previous analysis and compare the results. (15 points) 

 
 
Setting restrictions 
 
The most difficult part with this exercise is probably finding the streets and the corresponding arcs. You can 
use the Query Builder, or, with some local knowledge, you can just use the Select Feature tool and point and 
click in the view until you with the help of the street name field in the attribute table are able to find what you 
are looking for: 
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The image below shows the how the restrictions are reflected in the oneway field of the attribute table: 
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Next, create an empty turntable. You can create the turntable in ArcView, in Excel or simply in Notepad. If you 
do it in Notepad, remember that the fields (columns) need to be separated using Tab, not Space. 
 
The following values need to be contained in the turntable: 
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Upon re-running the analysis, not much is changed. The only restriction that actually affects the route is the 
no left turn at 4500 S and 2700 W, with the effect that the route continues straight on, makes a U-turn at the 
next intersection and then travels back again, see arrow: 
 

 


